2020年06月17日

Mac Pro 2010/2012のMojaveインストール

Mac Pro Mid 2010, Mid 2012は、macOS 10.14 Mojaveの正式対応機種になります。Metal対応のビデオカードを装着していること、が条件となります。この条件がついているのは、この機種だけ。これにより、Mojaveのインストールにちょっとした落とし穴が生じています。本ブログのコメント欄で話題になった件ですが、記事として上げておきます。Early 2009モデルでも、Firmwareを2010相当のMacPro5,1に上げていれば、同様です。

まず、Metal非対応のビデオカードを装着しているとどうなるか。以下のように表示され、インストールできません。

image















「このMacにmacOS Mojaveをインストールすることは、すべてのグラフィックカードがMetalに対応していて、FileVaultが無効になっている必要があります。このMacのインストール要件について詳しくは、https://support.apple.com/en-us/HT208898を参照してください。」

インストール条件を満たしていないので、これは仕方ないですね。当然の結果です。ところが、Metal対応のビデオカードを装着しているにもかかわらず、このアラートが出てしまうことがあるのです。 

macOSのインストール方法として、それまで使っていた旧OSに新OSをダウンロード、インストーラーを起動してインストールを行う方法と、USBメモリで起動用インストールメモリを作成しそこから起動してインストールする方法があります。上級者ほど、後者を好む傾向があるように思います。

USBメモリを使った方法でMac Pro Mid 2010, Mid 2012でMojaveインストールを開始すると、なんと上のアラートが表示されてインストールできません。一体なんで?
USBメモリで起動した際には、ビデオカードのドライバーも読み込まれませんので、Metalも機能しない状態で描画を行なっています。そのため、インストール可否判断をする時に、まずは機種の判定を行、MacPro5,1であれば、Metalが機能しているか確認するわけですが、機能していないため上のアラートが出る、ということのようです。他機種の場合は、Mojave対応機種であれば必ずMetal対応なので、機種判定のみで実際にMetalが機能しているかどうかの確認はされていないわけです。

というわけで、Mac Pro Mid 2010, Mid 2012の場合は、USBメモリを使ったインストールは行えず、High SierraからMojaveのインストーラーを起動してインストールを行う必要があります。これは、ちょっとした盲点ですね。 

vintagecomp at 09:27│Comments(5)テクニカル 

この記事へのコメント

1. Posted by Mac使い   2020年06月18日 10:03
私の環境は、Early 2009をMacPro5,1化して使っています。
Mojaveをインストールの際は、USBメモリを使った方法のみでインストールをしていますが、上記のエラーは出た事がありません。
使用しているビデオカードは、Radeon HD 7970 (MacEFI対応)です。
2. Posted by ワイ   2021年12月12日 21:06
よくブログを拝見させて頂いています。
古い記事にすみませんが、MacPro5.1(2012)にMojaveではなくLionをインストールしようと思ってAppleから落としたインストーラーをUSBに焼いてインストールしてみたらインストールは完了するもののその後の起動でカーネルパニックになり起動できませんでした。(USB焼き直しても同じでした)
カーネルパニックの内容はりんごが表示され、
→画面が暗くなる
→「コンピューターの再起動が必要です。電源が切れるまでパワーボタンを押し続けてから、もう一度パワーボタンを押します。」が表示されるのみで、コマンドのようなものは表示されません。
これは、プリインストールOSがMountain Lionだからインストールさせてもらえないのでしょうか?
Lionを触ってみたかったので解決法あれば指示いただけるとありがたいです。
3. Posted by Muto@VC   2021年12月15日 01:14
> これは、プリインストールOSがMountain Lionだからインストールさせてもらえないのでしょうか?

そういうことではないと、断言できます。非対応であれば、インストールの段階ではねられます。
原因は何かというのは難しいのですが、割と多いのがメモリです。OSにより微妙にメモリ要求スペックが異なり、インストール後に起動できないことがあります。メモリを複数枚使用しているのなら、1枚を抜いて起動、メモリを入れ替えて起動、を繰り返してみてください。
4. Posted by ワイ   2021年12月17日 19:39
メモリを複数枚使用しているのなら、1枚を抜いて起動、メモリを入れ替えて起動、を繰り返してみてください。>
今まで運用していたメモリ構成は16x3の48GBでしたが、4x3の12GBや4GBも試してみましたが起動せず、もしやDDR3Lを使ってるのがいけないのかと思って2x3の6GBのDDR3にしてみてもやっぱりダメ。
メモリの枚数も一枚4gbのメモリですべてのパターン試しましたがいずれも起動せず。
どうやらメモリの問題ではなさそうです…
5. Posted by Muto@VC   2021年12月20日 16:01
メモリでないとなると、難しいですね。
USBからのインストールではなく、HDDからのインストールを試して見るのも手だと思います。OSが起動しているHDDから、別HDDへのインストールはUSBからよりもトラブルが少ないように思います。

コメントする

名前
 
  絵文字
 
 
プロフィール

Harry

Archives